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Android App’s Anatomy 

• Android applications are usually created using the Java programming 
language [1] 

 

• Apps must import various Android Libraries (such as android.jar, maps.jar, 
etc ) to gain the functionality needed to work inside the Android OS. 
 

• Android apps are made of multiple elements such as:  user-defined 
classes, android jars, third-party libraries, XML files defining the UIs or 
views, multimedia resources, data assets such as disk files, external arrays 
and strings, databases, and finally a Manifest summarizing the ‘anatomy’ 
and permissions requested by the app. 
 

•  The various app components are given to the compiler to obtain a single 
signed and deployable Android Package (an .apk file).  
 

• Like “.class” files in Java, “.apk” files are the byte-code version of the app 
that finally will be ‘executed’ by interpretation inside either a Dalvik 
Virtual Machine (DVM) or an Android-Runtime Engine (ART).  
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[1] Visit http://xamarin.com/monoforandroid for a commercial iOS and Android IDE that works with C# and 
Windows .NET 

Applications (Apps) 

http://xamarin.com/monoforandroid


Android’s Byte-Code Execution  

The Dalvik Virtual Machine is a Just-in-Time (JIT) runtime environment 
(similar to the Oracle’s Java Virtual Machine JVM) that interprets Android 
byte-code only when it’s needed (however it will be phased out soon).  
 

The newer ART  (introduced as an option in Android 4.4 KitKat ) is an 
anticipatory or Ahead-of-Time (AOT) environment that compiles code before 
it is actually needed. 
 

ART promises: 
• enhanced performance and battery efficiency,  
• improved garbage collection,  
• better debugging facilities,  
• Improved diagnostic detail in exceptions and crash reports. 

 
Quoting from  
https://source.android.com/devices/tech/dalvik/art.html   (Aug-27-2014) 
 Important:  Dalvik must remain the default runtime or you risk breaking 

your Android implementations and third-party applications. 
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Dalvik Virtual Machine vs. Android Runtime (ART) 

https://source.android.com/devices/tech/dalvik/art.html


Android apps are made out of many components. The use of an IDE 
is strongly suggested to assist the developer in creating an Android 
solution. There are various options including: 
 
• Eclipse+ADT.  The classic general purpose Eclipse IDE can be 

enhanced (with the ADT plugin) to provide a ‘conventional’ way 
to create and debug Android Apps. The associated SDK Manager 
allows you to reach the various API libraries needed by the apps.  
 

• Android Studio is a new Android-only development 
environment based on IntelliJ IDEA. It is still on Beta form, but as 
soon as finished, it will be used as the ‘preferred’ IDE platform 
for Android development. 
 

• Netbeans+Android. Similar to Eclipse+ADT.  Soon to be 
deprecated(?) 
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Tools for Constructing Android Apps 

Development Workbenchs 



Opens DDMS  Perspective 
Dalvik Debugging Monitoring System 

Opens Android SDK manager 
 

Opens Android AVD Virtual Device 
Manager 

Wizard creates a new Android Project 
 

These icons 
are added to  
Eclipse by the 
ADT plugin 

Note: The DDMS and Hierarchy View can be manually added by the user to Eclipse’s tool bar 
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Eclipse + ADT + SDK 

Typical Layout of the Eclipse-ADT IDE for Android Development 
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Android Studio  

Layout of Android-Studio IDE 



We assume you have already installed the most recent Java JDK and Eclipse 
IDE in your computer 
 
• Java JDK is available at: 

http://www.oracle.com/technetwork/java/javase/downloads/index.html 
 

• Eclipse IDE for Java EE Developers is available at:  
http://www.eclipse.org/downloads/ 

 
 
The  next instructions are given to: 
 (a) User wanting to add a newer SDK to their existing collection,  
 (b) First time users (who may or not be Eclipse users). 
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Setting up Eclipse + ADT + SDK  

ECLIPSE  SETUP 
Prepare your computer – Install SDK: Windows, Mac, Linux 

http://www.oracle.com/technetwork/java/javase/downloads/index.html
http://www.eclipse.org/downloads/


1.5    Cupcake,  
1.6    Donut,  
2.1    Eclair,  
2.2    Froyo,  
2.3    Gingerbread ,  
3.x    Honeycomb, 
4.0    Ice Cream Sandwich 
4.3    Jelly Bean 
4.4    Kitkat   

SDKs are named after types of 
desserts. Available versions at 
the time of writing are: 

Statistics accessed on Aug 31st, 2014  from AppBrain at   http://www.appbrain.com/stats/top-android-sdk-versions 
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  Android SDK  
  Version 

  Current  
  market share 

  4.1-4.3 (Jelly Bean) 59.60% 

  4.4 (KitKat) 19.70% 

  2.3 (Gingerbread) 10.20% 

  4.0.x (Ice Cream  S.) 9.40% 

  2.2 (Froyo) 0.60% 

  3.0-3.2 (Honeycomb) 0.20% 

  2.0-2.1 (Eclair) 0.10% 

  4.5 (L Preview) 0.00% 

Setting up Eclipse + ADT + SDK  

An aside note… 

http://www.appbrain.com/stats/top-android-sdk-versions
http://www.appbrain.com/stats/top-android-sdk-versions
http://www.appbrain.com/stats/top-android-sdk-versions
http://www.appbrain.com/stats/top-android-sdk-versions
http://www.appbrain.com/stats/top-android-sdk-versions
http://www.appbrain.com/stats/top-android-sdk-versions
http://www.appbrain.com/stats/top-android-sdk-versions


1. Click on the          SDK 
Manager icon.  
 

2. You will see a form similar 
to the one on the right.  
 

3. Select the SDK packages 
and independent 
components you want to 
install (click ‘Install’ 
button and wait until they 
are setup in your 
machine…) 

 

(a) Users Wanting to Update an Older Android Workbench 
 
If you are currently using the Android SDK, you just need to update to the latest 
tools or platform using the already installed Android SDK Manager. 
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Setting up Eclipse + ADT + SDK  

(a) Users Wanting to Update an Older Android Workbench 



(b)  First Time Android Users who have Eclipse already  installed 
 
1. Obtain the appropriate (Windows, Max, Linux) Stand-alone SDK Tools for 

Windows from the page http://developer.android.com/sdk/index.html  
Execute the program,  remember the folder’s name and location in which 
the SDK is stored, you will have to supply this path to Eclipse. 
 

2. Install the ADT Plugin for Eclipse (it must be already available in your machine) 
1. Start Eclipse, then select Help > Install New Software.... 
2. Click Add button (top-right corner) 
3. In the next dialog-box enter "ADT Plugin" for the Name and the following 

URL for the Location: https://dl-ssl.google.com/android/eclipse/ 
4. Click OK 
5. Select the checkbox next to Developer Tools and click Next  > Next 
6. Accept the license agreements, then click Finish.  
7. After the installation end you need to restart Eclipse.  

 
3. Add Android platforms and other components to your SDK (see previous 

option (a) ) 
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Setting up Eclipse + ADT + SDK  

(b) First Time Android Users who have Eclipse already  installed 

http://developer.android.com/sdk/index.html
http://developer.android.com/sdk/index.html


Configure the ADT Plugin 
 
4.  The next step is to inform your Eclipse+ADT workbench of the android-sdk 
directory’s location (this is the path you saved on Step1) 
 

1. In Eclipse,  select Window > Preferences... to open the Preferences 
panel (Mac OS X: Eclipse > Preferences). 

2. Select Android from the left panel. 
3. To set the box SDK Location that appears in the main panel, 

click Browse... and locate your downloaded SDK directory ( usually 
C:\Program Files (x86)\Android\android-sdk )  

4. Click Apply, then OK. 
 
Done!  
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Setting up Eclipse + ADT + SDK  

Configure the ADT Plugin 



Selecting an Android Virtual Device (AVD) 
 
Ideally you should test your applications on a device (a physical phone or 
tablet).  However, the SDK allows you to create realistic virtual devices on 
which your applications could be executed/debugged before they are 
deployed on actual hardware..  
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Setting up Eclipse + ADT + SDK  

Working with Virtual Devices (AVDs) 



Creating an Android Virtual Device (AVD) 
 
An AVD allows you to simulated devices and prototype 
your solution on a variety of SDKs. To create a virtual 
unit follow the next steps: 
 
1. Click on the AVD Manager > Create. The Create New 

AVD wizard appears requesting your input. 
2. Type the name of the emulator, enter a value such 

as  “API19-Kitkat-442-Intel“  (see figure on the right) 
3. Select from the drop-downlist a Device (Nexus 4…) 

and CPU/ABI such as  Intel Atom (x86)  
4. Choose a target from the already installed SDKs   

(eg. “Android 4.4.2 - API Level19”). 
5. Tick the Keyboard box to enable your PC’s keyboard. 
6. Choose a skin of your preference (…dynamic hard …) 
7. Set memory RAM to no more than 768 MB 
8. Indicate how much internal storage the simulator 

will use (200MB). 
9. Add a small SD card ( 9MB ) 
9. Click OK to create the AVD. 
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Creating a Virtual Device (AVD) 

Setting up Eclipse + ADT + SDK  



AVDs  are saved in the folder: 
c:\Users\yourName\.android\avd\API19-Kitkat-442-Intel.avd 
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Setting up Eclipse + ADT + SDK  

A summary of the AVD specs  is  
saved in the /config.ini file 
 



Creating a Virtual Device (AVD)   
 
Some examples: 
 

IceCream 4.x 

Tablet showing Honeycomb 3.x 

Gingerbread 2.3 running on a custom skin 
for Nexus-S.   See page: 
http://heikobehrens.net/2011/03/15/android-skins/ 

On top, a phone emulator  
running IceCream 4.x 
wearing a HVGA skin 
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Setting up Eclipse + ADT + SDK  

http://heikobehrens.net/2011/03/15/android-skins/
http://heikobehrens.net/2011/03/15/android-skins/
http://heikobehrens.net/2011/03/15/android-skins/


Testing a Virtual Device (AVD)   
 
1. Invoke the AVD Manager.  
2. Choose an emulator, click Start. 
 

2 - 16   

Setting up Eclipse + ADT + SDK  



Running a Virtual Device (AVD)   
 
1. Invoke the AVD Manager.  
2. Choose an emulator, click Start. 
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Setting up Eclipse + ADT + SDK  



Hang up 

Back 

Volume  

Status Bar – Notification Line 

Home 

Call 

Menu 

Tab 
Launch 

Pad 

Power 

Search 

Camera 

ID 
number  

5554 
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AVD – Emulator wearing: HVGA Skin 
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Numeric ID:  
5554 

AVD – Emulator wearing: Skin with dynamic hardw. controls 



Keyboard OS function 
Escape Back button 

Home Home button 

F2,  PageUp Menu (Soft-Left) button 

Shift-F2,  PageDown Start  (Soft-Right) button 

F3 Call/Dial button 

F4 Hangup / EndCall button 

F5 Search button 

F7 Power button 

Ctrl-F3, Ctrl-KEYPAD_5 Camera button 

Ctrl-F5, KEYPAD_PLUS Volume up button 

Ctrl-F6, KEYPAD_MINUS Volume down button 

KEYPAD_5 DPad center 

KEYPAD_4 DPad left 

KEYPAD_6 DPad right 

KEYPAD_8 DPad up 

KEYPAD_2 DPad down 

F8 toggle cell network on/off 

F9 toggle code profiling  

Alt-ENTER toggle FullScreen mode 

Ctrl-T toggle trackball mode 

Ctrl-F11, KEYPAD_7 switch to previous layout 

Ctrl-F12, KEYPAD_9 switch to next layout 

Controlling an Android 
Emulator through your 
computer’s keyboard 
 
Note: Keypad keys only work when 
NumLock is deactivated. 
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Controlling the AVD Operations 



• The Android simulator uses QEMU technology [  Website: www.qemu.org  ]  
• QEMU is an open source machine emulator which allows the operating system and 

programs made for one machine (e.g. an ARM CPU) run efficiently on a different 
machine (e.g. your Windows PC).  

 
When you create a Virtual Device, the SDK  
Makes several  disk images containing among  
others:  
(1) OS kernel,  
(2) the Android system,   
(3) user data (userdata-qemu.img) 
(4) simulated SD card (sdcard.img). 
 
By default, the Emulator searches for the  
disk images in the private storage area of the  
AVD in use, for instance the “API16-JellyBean-412” AVD is at: 
C:\Users\yourFolder\.android\avd\API16-JellyBean-412 

 
Mac OS users should look into ~/.android/avd 

C:\Users\yourFolder\.android\avd\API16-JellyBean-412 
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AVD – Emulator : Disk Images 

Working with Emulator Disk Images 

http://www.qemu.org/


Upload/download Data, Music and 
Picture files to the Emulator’s  SDcard 

1. You need to add the DDMS 
perspective to your Eclipse IDE. 

2. Change to the DDMS perspective. 
Make sure your AVD has started 
(You will see a layout similar to the 
figure on the lower right side) 

3. Click on the File Explorer tab. 
4. Expand the mnt (mounted devices) 

folder. 
5. Expand the sdcard folder 
6. Open your Window’s Explorer. 
7. Choose a file stored in your PC. 

Transfer a copy to the emulator by 
dragging and dropping it on top of 
the sdcard folder. 
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Transferring Files to/from Emulator’s SD Card  
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Transferring Files to/from Emulator’s SD Card  

Upload/download Data, Music and 
Picture files to the Emulator’s  SDcard 



8. Return to the emulator. This time you may use native apps such as ‘Music’ and 
‘Gallery’ to see your recently uploaded multimedia files. For instance… 
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Transferring Files to/from Emulator’s SD Card  

Upload/download Data, Music and Picture files to the Emulator’s  
SDcard 



9.    Pictures may be displayed by clicking the Application Pad and invoking the 
Gallery application 
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Transferring Files to/from Emulator’s SD Card  

Upload/download Data, Music and Picture files to the Emulator’s  
SDcard 



After you complete your setup look for the following two subdirectories in 
your PC’s file system 

C:\Program Files (x86)\Android\android-sdk 

C:\Users\yourWindowsUserName\.android\avd 

This folder contains your Android 
SDK, tools, and platforms 

This directory holds your 
Virtual Devices (AVDs) 
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Setting up Eclipse + ADT + SDK  

Locate your ‘android-sdk’   &  AVD folder 



 

We will use Eclipse + ADT to create a 
bare bone app. All it is needed from 
the developer is to feed  the New 
Android Application wizard with a few 
selections (no extra code will be added 
to the default app skeleton generated 
by the IDE+SDK).  
 
The adjacent figures show the solution 
made by the wizard running on a Jelly 
Bean emulator and device. 
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Eclipse: Using the ‘New Android Application’ Wizard 

Example :  HelloWorld App 



Example :  HelloWorld App 
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1. Start Eclipse 
2. From menu choose File > New > 

Android Application Project  
3. Enter in the Application Name box:  

HelloWorldApp 
4. Enter Project name:  

HelloWorldAppProject  
5. Modify Package Name prefix to: 

csu.matos.helloworldappproject 
6. For Minimum Required SDK choose: 

API 10: Android 2.3.3 (Gingerbread) 
7. For Target SDK select the option:  

API 16:Android 4.1 (Jelly Bean) 
8.  Select for Compile With the option: 

API 16:Android 4.1 (Jelly Bean)  
9. Click Next 
10. Click Next 

Eclipse: Using the ‘New Android Application’ Wizard 



Example :  HelloWorld App 
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On the form Configure Launcher Icon 
do the following: 
 
11. Foreground > Clipart > Choose 
12. Select  an icon from the set of 

available images  > Close 
13. Pick a Foreground Color 
14. Click Next 
 

Eclipse: Using the ‘New Android Application’ Wizard 



Example :  HelloWorld App 
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The Create Activity form provides a 
number of basic templates from which 
your application could be constructed. 
 
15. Select the Blank Activity template. 
16. Click Next.  
 

Eclipse: Using the ‘New Android Application’ Wizard 



Example :  HelloWorld App 
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The Blank Activity form provides a way 
to name the main Activity and Layout 
name. 
 
17. Leave the default values shown in 

the form (Activity Name and Layout 
Name). 

18. Click Finish.  
 

At this point the wizard has completed 
all the steps required to make the app.  
 
After a few seconds the Eclipse  
perspective shows the app’s UI. The Java 
solution is shown in the PackageExplorer 
pane (see next pages)  
 

Eclipse: Using the ‘New Android Application’ Wizard 



Example :  HelloWorld App 

File Structure   
The folders and files shown on the 
figure are part of the newly created 
app.  
 
Here we are using Eclipse’s Package 
Explorer facility to navigate inside 
the folder holding the app. 
 
To test the application, position the 
cursor on the code panel, and then 
click on the Run menu button. 
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Eclipse: Using the ‘New Android 
Application’ Wizard 



Android apps are usually a complex collection of various type of components  
including Java code, multimedia resources, XML files, etc. The New Android 
Project Wizard facilitates the assembly of those parts and organizes the 
components in various directories of your app project space; among them: 
 
• src/ Includes your skeleton Activity Java file. All other Java files for your 

application go here.  
• <Android Version>/ (e.g., Android 4.1/) Includes the android.jar file that 

your application will build against.  
• gen/ This contains the Java files generated by ADT, such as your R.java file 
• assets/ This is empty. You can use it to store raw asset files.  
• res/ This folder holds application resources such as drawable files, UI 

layout files, string values, etc. 
• bin/ The bytecode (.apk) version of your app is stored here 
• AndroidManifest.xml The Android Manifest for your project.  
• default.properties This file contains project settings, such as the build 

target.  
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Eclipse: Using the ‘New Android Application’ Wizard 

File Structure of a Typical Android App 



Login into the Android OS shell 

34 
Android Emulator – Looking Under the Hood 

• Although it is not 
necessary, a developer 
may gain access to 
some of the innermost 
parts of the Android 
OS.  
 

• For a Unix-like 
experience you can log 
into the system by 
executing the emulator 
and issuing selected 
shell commands. 
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Login into the Android OS shell 

  adb is a tool located in the directory: 

  C:\Your-SDK-Folder\Android\android-sdk\platform-tools\ 

35 

STEPS 
1. Use the Eclipse AVD 

Manager to start one 
of your AVDs ( say 
Gingerbread23) 

 
2. At the DOS command 

prompt level run the 
Android Debug Bridge 
(adb) application  

  
 adb  shell          
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Android Emulator – Looking Under the Hood 



If more than one emulator is running (or your phone is physically connected to the 
computer using  the USB cable)  you need to identify the target.  
 
Follow the next steps: 
 
1. Get a list of attached devices 
 

   adb devices 
 

List of devices attached 

emulator-5554   device 
emulator-5556   device 
HT845GZ45737    device 
 
 

2. Run the adb application as follows:   

 adb  -s emulator-5554  shell 
 
Remember, the adb tool is located at C:\Program Files (x86)\Android\android-sdk\platform-tools\  
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Android Emulator – Looking Under the Hood 

Login into the Android OS shell 



 
 
 
Android accepts a number of Linux shell commands including the useful set below 

ls ................. show directory (alphabetical order) 

mkdir .............. make a directory 

rmdir .............. remove directory  

rm -r .............. to delete folders with files 

rm ................. remove files 

mv ................. moving and renaming files 

cat ................ displaying short files 

cd ................. change current directory 

pwd ................ find out what directory you are in 

df ................. shows available disk space 

chmod .............. changes permissions on a file 

date ............... display date 

exit ............... terminate session 
 

There is no copy (cp) command in Android, but you could use cat instead.  
For instance:   
 
 # cat data/app/theInstalledApp.apk > cache/theInstalledApp.apk  
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Android Emulator – Looking Under the Hood 

Login into the Android OS shell 



If you want to transfer an app that is currently installed in your rooted developer’s 
phone to the emulator, follow the next steps: 
 
1. Run command shell:  > adb devices  (find out your hardware’s id, say 

HT096P800176) 
 

2. Pull the file from the device to your computer’s file system. Enter the command 
 adb -s HT096P800176 pull data/app/theInstalledApp.apk   

c:\theInstalledApp.apk 
 

3. Disconnect your Android phone 
 

4. Run an instance of the Emulator 
 

5. Now install the app on the emulator using the command 
 adb -s  emulator-5554  install c:\theInstalledApp.apk 
 adb -s  emulator-5554  uninstall data/app/theInstalledApp.apk   ⟵ to uninstall 
 
You should see a message indicating the size of the installed package, and finally: 
Success. 
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Android Emulator – Looking Under the Hood 

Hacking:  Moving an app from a Rooted Phone to the Emulator 



Visit Google Play Store and choose a user-friendly file manager app from the various 
(usually very good) options available.   
 
A file manager app allows you to easily administer the folders and files in the system’s 
flash memory and SD card of your Android device (or emulator). 
 

A sample of File-Management apps seen at https://play.google.com on Aug-27th -2014 
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Android Emulator – Looking Under the Hood 

Simpler than Hacking:  Install  a File Manager for Android 

https://play.google.com/


Using an alternate SD card & userData Image 

Additional Emulator Command Line Options: 
      -sdcard   c:\My_Emulator_Data\myreallybigsdcard.img   -datadir    c:\My_Emulator_Data   

From the Eclipse menu create a  
new launch configuration:  
   Run > 
   Run Configurations >  
   New icon   
 
On the Target panel: 
  
1. Select existing AVD (Gingerbread 

in this example) 
2. Enter additional Command Line 

Options (see caption below) 
3. Click on Apply > Run  
 

2 - 40   

Android Emulator – Looking Under the Hood 



1. Start the emulator.  
 

2. Open a new DOS command shell and type : 
c:>  adb devices 
this way you get to know the emulator’s numeric port id (usually 5554, 
5556, and so on)  
 

3. Initiate a Telnet session with the sender at localhost, port 5556 identifies 
an active (receiving) Android emulator. Type the command: 
 c:>   telnet localhost 5554  
 

4. After receiving  the telnet prompt, you can send a text message to the 
emulator on port 5554 (no quotes needed for the message) 
sms  send  <Sender’s phone number>  <text message> 

Windows7 – temporarily  install Telnet Client by using a command line 
1. Click Start button, type cmd in the ‘search programs and files’ box, and then press ENTER. 

2.    Type the following command:    pkgmgr /iu:"TelnetClient” 
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Android Emulator – Simulate Texting 

Sending Text Messages from your Window’s PC to the Emulator  



Sending a text Message (SMS)  
from your PC to the Emulator  
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Android Emulator – Simulate Texting 



Making a Phone Call from your PC to the Emulator  
 
1. Start the emulator.  

 
2. Open a new shell and type : 

adb devices 
to know the emulator’s numeric port id (usually 5554, 5556, and so on)  
 

3. Connect to the console using telnet command like: 
telnet  localhost  5554     (5554 is the ‘phone number’ to be called) 
 

4. After receiving  the telnet prompt you can place a call (voice) with the 
command  
gsm call <caller’s phone number> 
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Android Emulator – Simulate Phone Calls 

Making a Phone Call from your PC to the Emulator  



Example:  
Making a Phone from your PC to the 
Emulator  
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Android Emulator – Simulate Phone Calls 



It is much simpler to test telephony operations (SMS/Voice) as well as GPS 
services using the controls included in the Eclipse DDMS perspective  
 
1. Telephony Status - change the state of the phone's Voice and Data plans 

(home, roaming, searching, etc.), and simulate different kinds of network 
Speed and Latency (GPRS, EDGE, UTMS, etc.). 
 

2. Telephony Actions - perform simulated phone calls and SMS messages to 
the emulator. 
 

3. Location Controls - send mock location data to the emulator so that you 
can perform location-aware operations like GPS mapping.  
• Manually send individual longitude/latitude coordinates to the 

device.      Click Manual, select the coordinate format, fill in the fields 
and click Send.  

• Use a GPX file describing a route for playback to the device.  
• Use a KML file to place multiple placemarker points on a map 
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Using Eclipse’s DDMS facility 
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Send text-messages 
Make a phone call 
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Using Eclipse’s DDMS facility 
 

DDMS Telephony Services 



 
Lesson 2: 

Android Setup & Emulator 

Questions ? 
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Connecting your Physical Device to the Computer 
1. Make sure the USB driver has been installed in your PC ( click         SDK Manager > 

Extras > check box [Google USB driver package] to install ) 
2. Use a mini-USB cable to connect the device to your computer. 
3. Expand the Notification bar. Click on [USB connected] option.   
4. Click on [Turn on USB storage ] to mount the device. 
5. Now you could now use the Eclipse-ADT-File Explorer and your Window’s Explorer 

tool to pull/push/delete/rename files to the device. 
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Appendix 1 - Using a Hardware Device 
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1. Run two instances of the emulator (typical IDs are: 5554, 5556, … ) 
2. Dial (or send SMS) from one of them (say 5554) to the other (5556) 
3. Press the Green/Red call buttons to accept/terminate the call 
4. Try sending SMS (use numbers 5554 and 5556) 
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Appendix  2 – Emulator-to-Emulator Interaction 
 



1. o to your Gmail account using a web browser, click on Gmail  > 
Contacts on the left sidebar.  
 

2. Select all the contacts you want on your emulator/phone. Then 
click on More > Export and select vCard format.  Download the 
“contacs.vcf” file to your PC. 
 

3. Push the contacs.vcf file from the PC to the emulator’s SD card. 
 

4. Open the emulator’s  Contacts app hit Menu > Import.  
 

5. Choose the option Import from SD card. 
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Appendix 3 – Sync your Contacts 
 

Source visited on July 2009, link:  
http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator 

 

How to Transfer Your Google Contacts into the Emulator  

http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator
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